Extending the Library

Top  Previous  Next

 

 

This tutorial walks you through the process of extending Genetica's library so that you can speed up your workflow by reusing parts of your work in multiple textures.  Along the way we will also take a closer look at how Group nodes work, and how to make our own custom noises.

 

 

Step 1

 

In this tutorial we will create a swirly paint texture.  The first half of this tutorial will focus on creating our own custom noise that will form the basis of this texture.  (A noise is a colorless, yet detail-filled pattern that gives a texture its character.)

 

Start by creating a new blank texture document.  To do this, click File > New in the main menu.  A new texture can also be created by clicking the very first button appearing in the main button bar.  Then switch to the Nodes tab.

 

 

Step 2

 

A single blank slot should now be visible in the middle of the Nodes tab's workspace (it looks like a black box with the word "<Empty>" in it). Insert a Noise node (found in the Libraries, Image Nodes, Generate category) into the slot using either of the following techniques:

1.In the upper portion of the Library panel (which appears at the right side of the interface whenever the Nodes tab is active), select the Libraries, Image Nodes, Generate category, then find the Noise node in the lower portion of the Library panel, and finally drag it onto the blank slot.  (For an illustration of this process, refer to Step 2 of the Making an Animation tutorial.)
2.Alternatively, click the "<Empty>" label found within the blank slot, and in the box that appears type "noise".

 

In the properties panel at the bottom of the interface you will now see a number of properties controlling the behavior of our newly-added Noise node.  Let's use those properties to make the noise look a little more interesting. Change the Smoothing property to "Cosine" and then set the Iterations property to 5.

 

 

Step 3

 

Our Noise node is a good start, but it will need to be modified for it to have the swirly pattern we're looking for.

 

Insert a Group node (found in the Libraries, Image Nodes, Group category) below the Noise node using either of the following techniques:

1.In the Library panel, select the Libraries, Image Nodes, Group category, then drag the Group node from the panel and drop it onto the bottom edge of the Noise node.  (Note the importance of concluding the drop operation on the bottom edge of the Noise node.  For an illustration of this, refer to Step 2 of the Weathering a Texture tutorial.)
2.Alternatively, click the bottom edge of the Noise node, and in the box that appears type "group" followed by the Enter key.

 

 

Step 4

 

Your workspace should now contain two nodes, as illustrated below.

 

 

Blank Group

 

 

Group nodes, like the one we just inserted, function by packaging a number of other nodes within them.  Our newly-inserted Group appears black because it is empty.  Notice how the Noise node is sitting directly above the Group, and is connected by a wire.  This means that the Noise node is the Group node's input, which in turn means that the image produced by the Noise node can be reused multiple times by the nodes hiding within the Group.

 

In order to view the Group's contents, click the Enter button appearing over the top-right corner of the Group node.

 

The workspaces should now have updated to show the nodes contained within the Group.  Because the Group is currently empty, these contents are represented by a single empty slot in the middle of the workspace.

 

The left part of the status bar running along the bottom of the interface should now read "View: New Texture X > Group," where 'X' corresponds to some number identifying the unsaved texture.  This can be read as "The workspace view is currently showing the contents of 'Group' which is within 'New Texture X.'"  Directly below the empty slot in the middle of the workspace is a button labeled "Out".  Whenever you are finished editing the contents of a Group, you can click this button to move the view back to the level you were previously working in before entering the Group.

 

Insert a Distort node (found in the Libraries, Image Nodes, Transform category) into the empty slot.  (For a recap of the various ways this can be done, please refer to Step 2.)

 

The Distort node will distort whatever node is placed in its first input (the top-left square that has the word "Original" along its bottom).  Since that input is currently empty, the Distort node isn't doing anything at the moment.

 

If you recall from earlier within this step (illustrated by the previous image), we have a Noise node acting as the Group's input.  Now that we are within the Group (we moved into the Group by clicking its Enter button), that input appears as a thumbnail in the inputs bar that runs along the top of the workspace. First drag the group input into the Distort node's "Original" slot, then drag the group input into the Distort node's "Distance" slot, as shown by the following illustration.

 

 

Drag Group Inputs

 

 

Step 5

 

Now that our original Noise node is being distorted, it looks a lot more interesting.  However, some unwanted horizontal bars are moving through the noise because the distortion is only occurring in one direction throughout the texture.  We would like to vary the direction in which the distortion occurs.

 

To do this, insert a new Noise node into the Direction slot (the slot above the middle of the Distort node).  (Note: Don't drag the input from the Group Inputs panel like we just did in the previous step, rather insert a completely new Noise node as was done in Step 2.)  Our texture is looking a little too swirly now, so change both the Width (W) and Height (H) portions of the Size property of our newly inserted Noise node to 0.5.  The Size property can be found in the Properties panel while the node is selected.

 

 

Step 6

 

Open the Save As dialog by selecting File > Save As from the main menu (since the texture is unsaved, clicking the large disk icon on the main button bar would currently have the same effect). Navigate to where you want to save this texture, then create a new folder named Custom Noises.  Enter that folder, type Swirl Noise into the file name field, then click the Save button.

 

If you wish you may close the texture at this point, by either clicking the little 'X' at the far right side of the button bar, or by selecting File > Close from the main menu.

 

 

Step 7

 

In the previous steps we saved our custom noise under the name "Swirl Noise."  In this step we will add that noise directly to Genetica's interface so that it can be easily reused in future textures.

 

Select Edit > Preferences... in the main menu and then clicking the "Edit..." button appearing next to the "Texture Library Folders" label.

 

 

Texture-Library-Folders

 

 

A dialog window should have popped up which allows you to specify which folders on your hard drive are to be opened as libraries. You should see a number of empty slots, each one of which can be set to a particular folder.

 

Pick which slot you want to use (it doesn't matter which), and click its "Select..." button.

 

In the folder browser that pops up, locate the "Custom Noises" folder that you created in the previous step and click it. Then click OK. Finally, close the Select Library Folders dialog.

 

Your "Custom Noises" folder, along with the "Swirl Noise" texture that you saved within it, should now appear within the Library panel as well as the right-click menu.  This means that our newly constructed Swirl Noise can be inserted into any of your textures just as easily as any of the other nodes that we've been using throughout these tutorials.  Your Custom Noises folder will also appear among the texture categories in the Overview tab.

 

 

Step 8

 

Now that we've added our new noise to Genetica's interface, let's use it. Start a new document, then switch to the Overview tab.  Select the "Legacy Presets/Tile" category and then select the "Painted Tiles" preset texture.

 

Switch to the Nodes tab and enter the group.  You should see a Substance Lab node followed by a Sharpen node. Insert our Swirl Noise into the empty slot directly above the Substance Lab.  As before, this can be accomplished by either dragging the Swirl Noise icon from the Library Panel after selecting the Custom Noises category, or by right-clicking the blank slot above the Substance Lab and then selecting Insert > Custom Noises > Swirl Noise.

 

 

Inserted Swirl Noise

 

 

The workspace should now resemble the above image.

 

Although we've inserted the noise into the Substance Lab's input, the resulting texture hasn't changed because the Substance Lab won't make use of its input noise until we tell it to.  To access the Substance Lab's settings, click the Edit button appearing directly over the top left corner of the Substance Lab.

 

Genetica will now have switched to the Substance Lab's properties tab.  As illustrated in Step 4 of the Editing Presets tutorial, Lab properties are organized into a number of sections. Select the "Noise" section.

 

A number of properties will appear to the right of where you clicked that define the noise currently used by the Substance Lab.  We want to update those options to use our input noise instead.  Within the properties there will be three "Select Type..." buttons. Click the first of the three "Select Type..." buttons, and in the window that pops up, select "Use Input" (it will be the second icon in the popup window).

 

Our swirly paint texture is now ready to be rendered!

 

 

Swirly Paint Texture

 

 

Next: The Zooming Textures tutorial introduces the mechanics of zooming textures in order to change the size of their features as well as make them repeat more or less often.

 

 


Page URL: http://www.spiralgraphics.biz/genetica/help/index.htm?extendingthelibrary.htm