Using Effect Maps

Top  Previous  Next

 

 

This tutorial shows you how to generate various effect maps, such as bump and specular maps, for use in your external 3D application.

 

Originally texture artists worked with only a few channels: red, green, and blue channels were used to specify how much of each color was present at every pixel, with possibly an alpha channel to dictate how opaque a given pixel was.

 

Modern 3D environments give texture artists a slew of additional material channels to work with.  The specular channel, for example, controls how shiny each pixel is, allowing some parts of a material to glint as they catch the light, while the bump channel helps give your materials a three-dimensional appearance.  Channels such as these have allowed texture artists to create materials of unprecedented realism, but have also required artists to spend more time creating additional image maps for each texture.

 

Effect maps are Genetica's answer to the additional channels required by modern textures.  They will not only save you time, but have been designed to allow maximum flexibility in how they are used.

 

 

Three Spheres

 

 

Unlike traditional color channels, there is no right or wrong correspondence between effect maps and the channels they are used in.  As shown above, by experimenting with the numerous effect maps provided by Genetica, you can create materials that lend significantly different feelings to your final scene.  For example, while Genetica's effect maps have been used to give the material to the left a bubbly, cobblestone-like appearance that makes it more appropriate for an outdoor environment, the material to the right has been given a smoother, more polished look that is better suited for indoors.  Meanwhile, effect maps were used with the middle version to fill its grooves with grime, making it more appropriate for a dungeon environment.

 

 

Step 1

 

In the Overview tab, select the "Legacy Presets/Tile" preset category, then click the "Earthy Brown Herringbone" preset texture.

 

Let's explore the texture we just opened to better understand the effect maps that it contains.  Because you have just opened this texture, the Cut & Tile Lab at the very bottom of the texture tree should be selected--make sure that this is the case.  In the panel to the left of the interface you will find a tab labeled "Effect Maps." Click the Effect Maps tab to bring it up.  You will now see a number of grayscale images with titles such as "Mortar Height Map" and "Bevel Height Map."

 

Because the very root node of the texture is selected, these are the effect maps that correspond to the entire texture.  We aren't limited to using the texture as a whole.  Instead, by making use of the Render Branch button Render-Branch, we can render any portion of the texture that corresponds to the currently selected node.  The effect maps appearing in the Effect Maps tab will change depending on what node is currently selected. Select the Substance Lab that appears in the main workspace.  Your interface should now resemble the following illustration.  Notice how two new effect maps appear to the left of the workspace that correspond to the currently selected node.

 

 

Effect-Maps

 

 

Step 2

 

Now we will turn our attention to rendering the texture and its effect maps for use in our 3D environment.  You will notice that like most textures created in Genetica, the preset that we just opened has highlights and shadows baked directly into the texture itself, giving the tiles a three-dimensional appearance.  However, these highlights and shadows may not correspond to the position of the actual light source in our final scene.  We will therefore activate the Color Only Render option in order to strip away these baked highlights from the texture, allowing our 3D environment to add its own highlights as needed.  The following image shows how the texture will look with and without color-only rendering active.

 

 

Color Only Render

 

 

Set the render resolution to 512 x 512.  Activate both the Color Only Render and Render Effect Maps options.  Notice the check marks next to these two options in the Render menu.

 

 

Effect-Maps-2

 

 

Click the Render Texture button.

 

 

Step 3

 

After the texture is finished rendering, Genetica will automatically switch to the Results tab.  Due to the Color Only Render option that was activated before rendering, the texture should appear flat.  Your interface should now resemble the following illustration.

 

 

Effect Maps Render Tab

 

 

First we'll save the color-only version of the texture, which should already be selected and visible in the Results tab. Save the image to your hard drive by either clicking the Export Image button found on the Results tab's button bar, or by clicking File > Export Image.

 

Next we will examine the available effect maps to determine which ones we want for our final scene.  As indicated in the image above, you can use the drop-down within the Results tab to switch between effect maps.  Which effect maps we choose to use with which material channels in our 3D environment is largely a matter of taste.  As indicated by the very first illustration in this tutorial, a vast range of results are achievable by using different effect maps in different ways.

 

For this tutorial we will make use of three of the effect maps, as described below.

 

 

Effect Maps Used

 

 

You may have noticed from the previous illustration that we intend to use both the displacement channel and the bump channel of our external 3D application.  The reason is that displacement channels excel at defining the overall thickness of a material since they actually modify the geometry of the shape itself.  Bump channels, on the other hand, are better at creating the very fine bumps on a material's surface.  But as mentioned throughout this tutorial, which effect maps you use in which channels depends largely on taste.  If you wanted to do the job using a single channel, for example, you could try the "Combined Texture" effect map which combines both tiny details and overall elevations.

 

Save the "Combined Height Map" effect map by first selecting it using the effect map drop-down, then by clicking the Export Image button, both of which are indicated in the image before last.  Please note that if you are working in a real-time game environment, you may need to convert the image into a normal map by clicking the Make Normal Map button (also indicated in the image before last) before saving the image.  The Make Normal Map option is available in the Pro and Studio editions of Genetica.

 

Repeat those steps to save the "Tile and Mortar" effect map and the "Tile Material" effect map.

 

 

Step 4

 

Create a shader in your external 3D application.  Assign the color-only map that you saved to the color channel of the shader.  Assign the "Combined Height Map" effect map to the displacement channel.  Assign the "Tile and Mortar" effect map to the bump channel.  Assign the "Tile Material" effect map to the specular channel.

 

Please note that what channels are available to you will depend on your specific 3D environment.  For example, if you are working with a real-time game engine, you may not have a displacement channel available, but you may have a parallax shader instead which will serve the same purpose.  Please consult your 3D environment's documentation for more details.

 

The following image shows our shader assigned to simple sphere and plane objects, illuminated by a spotlight.

 

 

Effect Map Sphere

 

 

 

Now that we have learned how to make use of effect maps to enhance a material, let's take a closer look at the first illustration of the tutorial.

 

 

Three Spheres

 

 

You will recognize the first of the three versions as the material we constructed in this tutorial.

 

The second version of the material is very similar, except the "Combined Texture" effect map was placed in the material's diffuse channel.  Diffuse channels control how much light reaches various parts of the material.  In this situation it was used to create the impression that dirt has settled into the deeper cracks of the texture, making it appropriate for a dungeon environment.

 

The opposite approach was taken for the third sphere.  In this case a modern, reflective floor was sought after, with the tiles more reflective than the mortar.  To achieve this, the "Combined Texture" effect map was placed in the reflection channel, illustrating how the same effect map used to make the middle sphere look older could also be used to make the rightmost sphere look newer.  Other changes included strengthening the specular highlight and removing the displacement channel to flatten the material.

 

Next: The Making Website Thumbnails (Pro/Studio) tutorial shows you how to use the Pro edition's batch processor to quickly turn a number of textures into thumbnails for display on your website.

 

 


Page URL: http://www.spiralgraphics.biz/genetica/help/index.htm?usingeffectmaps.htm